[MarkLogic Dev General] CQ Versioning and Bugginess

Shannon Shiflett sss4r at virginia.edu
Wed Jun 27 12:05:47 PDT 2007


yeah, i know--jose thought i should mention it here, it's not really  
on my radar.
shannon

On Jun 27, 2007, at 3:03 PM, Michael Blakeley wrote:

> Per http://developer.marklogic.com/code/ "Supported browsers are  
> Mozilla 1.0+ and Internet Explorer 6.0+. Some features may not work  
> on other browsers." The buffer list counts as a feature.
>
> It's open source, so why not help out? I've accepted a couple of  
> patches for Opera. If you have a patch for Safari, I can try to  
> integrate it.
>
> -- Mike
>
> Shannon Shiflett wrote:
>> fyi: & while we're on the subject, this is what the buffer pane  
>> looks like in Safari 3 on OSX using cq 3.2 -- was fine in previous  
>> version.
>> On Jun 27, 2007, at 2:49 PM, Engelke, John wrote:
>>> Hello,
>>>
>>>
>>> Since it is not recommended to run a newer CQ with an older  
>>> server, i.e. CQ 3.2.2 with ML Server version 3.1-5, I use CQ  
>>> 2.2.0 with ML Server 3.1-5 whenever I run into weirdness. (Found  
>>> at http://xqzone.marklogic.com/svn/cq/trunk/README.txt and  
>>> implied by http://xqzone.marklogic.com/svn/cq/releases/ .)
>>>
>>>
>>> Question: Out of curiosity, is there a way -- without looking at  
>>> source -- to know exactly which version of CQ is running? Does ML  
>>> release point builds of CQ?
>>>
>>>
>>> Bugginess: Has anyone experienced problems importing namespaces  
>>> into CQ 3.1.0 – I have never been able to do this, and I believe  
>>> it is a bug. Here is some sample code and here is an error. This  
>>> works fine in CQ 2.2 but not at all in CQ 3.1.0 on my Windows box.
>>>
>>>
>>> Example Code:
>>>
>>>
>>> import module namespace  
>>> dd='com.edmunds.theApplication.theModelContainer.theModel' at '/ 
>>> com/edmunds/theApplication/theModelContainer/theModel.xqy'
>>>
>>>
>>> dd:get-myValue();
>>>
>>>
>>> Returns something like this:
>>>
>>>
>>> |*ERROR: eval-in multimedia at file:./C:\dev\perforce\SomePath 
>>> \xqyRoot\someDir*|*
>>>
>>> |SVC-FILOPN: File open error: open './C:\dev\perforce\SomePath 
>>> \xqyRoot\SomeDir\com\edmunds\theApplication\theModelContainer 
>>> \theModel.xqy': Invalid argument|
>>>
>>> |/Stack trace:/|
>>>
>>> |line 1: |*
>>>
>>> |*1: import module namespace  
>>> dd='com.edmunds.theApplication.theModelContainer.theModel' at '/ 
>>> com/edmunds/theApplication/theModelContainer/theModel.xqy'*|*
>>> |2: |
>>> |3: dd:get-myValue();|*
>>>
>>> *
>>> *
>>> The function works fine in inline code and in CQ 2.2.0. Frankly,  
>>> I think there is some path issue with CQ 3.1.0 on Windows boxes  
>>> (and no I haven’t yet checked this on a Unix box). Please note  
>>> that I obfuscated some of the path names above for security  
>>> reasons but they are all consistent.
>>>
>>>
>>> Any advice, knowledge and/or assistance in resolving this  
>>> irritant would be greatly appreciated.
>>>
>>>
>>> Regards,
>>>
>>>
>>> John Engelke
>>>
>>>
>>>
>>> _______________________________________________
>>> General mailing list
>>> General at developer.marklogic.com  
>>> <mailto:General at developer.marklogic.com>
>>> http://xqzone.com/mailman/listinfo/general
>> --------------------------------------------------------------------- 
>> ---
>> _______________________________________________
>> General mailing list
>> General at developer.marklogic.com
>> http://xqzone.com/mailman/listinfo/general
>
>
> _______________________________________________
> General mailing list
> General at developer.marklogic.com
> http://xqzone.com/mailman/listinfo/general



More information about the General mailing list