[MarkLogic Dev General] Upgrade 3.2-7 to 4.0-1

Wayne Feick wayne.feick at marklogic.com
Thu Oct 23 09:14:20 PDT 2008


Hi Wyatt,

This is an SELinux issue. We do not yet support running with SELinux
enabled. As a work around, you could disable SELinux completely

        # setenforce 0

or you could just disable the two things we've seen trigger for our
server so far.

        # setsebool -P allow_execstack=1
        # setsebool -P allow_execmod=1

This has seemed to work for other CentOS users, although I cannot
guarantee that you won't encounter some other SELinux issue in the
future.

If you know how to create an SELInux policy module, you could take the
more surgical approach of creating one that only permits execstack and
execmod for our binary. The commands above permit them for all binaries.

Wayne.


On Thu, 2008-10-23 at 11:51 -0400, Wyatt VanderStucken wrote:

> I'm trying to upgrade from MLS 3.2-7 to 4.0-1 on CentOS 5.2...  I 
> followed the upgrade instructions in the Installation Guide, but but 
> when I try to start MLS I'm getting:
> 
> Starting MarkLogic: /opt/MarkLogic/bin/MarkLogic: error while loading 
> shared libraries: Basis/lib/libbteuclid.so.6.0.1: cannot restore segment 
> prot after reloc: Permission denied
>                                                            [FAILED]
> 
> I have tried chmod 777 on libbteuclid.so.6.0.1 to no avail - any 
> suggestions???
> 
> Thanks,
> Wyatt
> 
> _______________________________________________
> General mailing list
> General at developer.marklogic.com
> http://xqzone.com/mailman/listinfo/general
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://xqzone.marklogic.com/pipermail/general/attachments/20081023/d9dcba69/attachment.html


More information about the General mailing list