[MarkLogic Dev General] Corona Questions

Randy Smith randy.smith at msic.dia.mil
Thu Mar 22 14:01:12 PDT 2012


Geert,
I'm running the latest copy (a few days old).

  I just found that when I do 
|http//myhost:8011/search?stringQuery=cat&outputFormat=xml | I now get 
back an xml file in the search results format  indicated in the 
documentation. That has got to be a good sign!!! :-) The only problem is 
that the "results" tag is empty. The meta tag also comes back but has 
all zeros.
This is the xml file as it comes back in the browser:
*
<corona:response>
<corona:meta>
<corona:start>0</corona:start>
<corona:end>0</corona:end>
<corona:total>0</corona:total>*
*<corona:executionTime>0S</**corona:executionTime>*
*</corona:meta>
<corona:results/>
</corona:response>*

Note that the executionTime comes back with something like .01 if I 
leave off the "outputFormat=xml. So, that works if it thinks it is JSON.

Hope this offers some clues!
Thanks for the help!
Randy
On 3/22/2012 3:23 PM, Geert Josten wrote:
>
> Hi Randy,
>
> A 404 likely means the endpoints config is wonky. Are you running 
> latest copy from git? The 500 indicates something goes wrong 
> internally. Can you tell what response you are getting exactly? In 
> case of a 500, there should be more details in the response body.
>
> Kind regards,
>
> Geert
>
> *Van:*general-bounces at developer.marklogic.com 
> <mailto:general-bounces at developer.marklogic.com> 
> [mailto:general-bounces at developer.mar 
> <mailto:general-bounces at developer.mar>klogic.com <http://klogic.com>] 
> *Namens *Randy Smith
> *Verzonden:* donderdag 22 maart 2012 20:17
> *Aan:* General MarkLogic Developer Discussion
> *Onderwerp:* [MarkLogic Dev General] Corona Questions
>
> All,
> Trying to come up to speed with the Alpha version of Corona. i.e. the 
> REST connection to MarkLogic.
> *BTW this is what I really need so thanks to the developer group!*
>
> I want to use it with a .NET app, i.e. send http queries, requests, 
> etc and use the MarkLogic results in the .NET app.
> Firs,t this is my view of how Corona works which may not be correct:
>     - Http app server receives the REST message based on documentation 
> rules i.e. server http address; service name; options etc... for the 
> particular service.
>     - Uses the library of apps to query or do whatever to the 
> MarkLogic db it points to.
>      - Packages the results and returns the results via Http to 
> fulfill the request.
>
> History of what I've done:
> 1. I've got Corona installed according to the instructions (I hope :-) ).
> 2. Ran the test/index.html test suite.
>     - A lot of the tests run ok. Some do not. Not sure if this is 
> because it is Alpha code or my error.
> 3. Pointed the http app server to the top-songs database we used in 
> class as a test.
> 4. Note that the "setup" process added several Element Range Index to 
> the database, i.e. rangeEl, fromPersonal, rangeKey, both string and 
> decimal.*_Is this normal?_*
> 5. Almost everything I've tried from the .NET app or just adding the 
> http call in a browser gives a 404 or 500 error.
>     - |For example:|
> |        
> http//myhost:8011/kvquery?element=artist&value=Michael%20Jackson&contentType=xml|
>
> |        http//myhost:8011/search?stringQuery=cat|
>
> |        
> http//myhost:8011/store?uri=/songs/Air-Supply+The-One-That-You-Love.xml&contentType=xml|
>
>
> Any ideas on where to look to get Corona to begin to talk back to me?
> Thanks,
> Randy
>
>
> _______________________________________________
> General mailing list
> General at developer.marklogic.com
> http://developer.marklogic.com/mailman/listinfo/general
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://developer.marklogic.com/pipermail/general/attachments/20120322/a983a4ae/attachment-0001.html 


More information about the General mailing list