[MarkLogic Dev General] Corona Questions

Eric Bloch Eric.Bloch at marklogic.com
Fri Mar 23 09:41:39 PDT 2012


I know at one point Corona only knew about docs inserted via Corona, but I believe that behavior has changed.  Hm…

E




On Mar 23, 2012, at 9:25 AM, Randy Smith wrote:

Geert,
I ran the CQ search you suggested and lots of results came back for 'cat'. I am puzzled why it is not working. I even created a new version of the top-songs database which worked fine with CQ but with no results when running the Corona test.

I looked over the installation but did not see any problem. I wonder if there could be a permission problem. Are the two Corona accounts that were created when Corona was setup involved when running Corona? I am currently running as admin when I run my tests.
Thanks for the help so far.
Ideas?
Randy

On 3/23/2012 1:36 AM, Geert Josten wrote:
Hi Randy,

The reason I asked is because you aren’t getting back results. That sounds either that there really aren’t any docs containing the word ‘cat’ (less likely I thought), or you are running against an empty database. Did you double check? You could also run a test query in Query Console (or CQ if you are using ML 4) to make sure, with something like:

cts:search(collection(), ‘cat’)

(and selecting the correct database in the console of course..)

Kind regards,
Geert

Van: general-bounces at developer.marklogic.com<mailto:general-bounces at developer.marklogic.com> [mailto:general-bounces at developer.marklogic.com<mailto:general-bounces at developer.marklogic.com>] Namens Randy Smith
Verzonden: donderdag 22 maart 2012 22:38
Aan: MarkLogic Developer Discussion
Onderwerp: Re: [MarkLogic Dev General] Corona Questions

Geert,
Eric is correct, I point it to the top-songs database we used in class. My app we did in class works against the same database so it should be ok. You said something about the config of Corona. I have not touched that. Is that a place to look for issues?
Randy

On 3/22/2012 4:18 PM, Geert Josten wrote:
Hi Randy,

Are you sure corona is running against the correct documents database? Your rest call works just fine with me, returning proper results..

Kind regards,
Geert

Van: general-bounces at developer.marklogic.com<mailto:general-bounces at developer.marklogic.com> [mailto:general-bounces at developer.marklogic.com<mailto:general-bounces at developer.marklogic.com>] Namens Randy Smith
Verzonden: donderdag 22 maart 2012 22:01
Aan: MarkLogic Developer Discussion
Onderwerp: Re: [MarkLogic Dev General] Corona Questions

Geert,
I'm running the latest copy (a few days old).

 I just found that when I do  http//myhost:8011/search?stringQuery=cat&outputFormat=xml  I now get back an xml file in the search results format  indicated in the documentation. That has got to be a good sign!!! :-) The only problem is that the "results" tag is empty. The meta tag also comes back but has all zeros.
This is the xml file as it comes back in the browser:

<corona:response>
    <corona:meta>
        <corona:start>0</corona:start>
        <corona:end>0</corona:end>
        <corona:total>0</corona:total>
        <corona:executionTime>0S</corona:executionTime>
    </corona:meta>
    <corona:results/>
</corona:response>

Note that the executionTime comes back with something like .01 if I leave off the "outputFormat=xml. So, that works if it thinks it is JSON.

Hope this offers some clues!
Thanks for the help!
Randy
On 3/22/2012 3:23 PM, Geert Josten wrote:
Hi Randy,

A 404 likely means the endpoints config is wonky. Are you running latest copy from git? The 500 indicates something goes wrong internally. Can you tell what response you are getting exactly? In case of a 500, there should be more details in the response body.

Kind regards,
Geert

Van: general-bounces at developer.marklogic.com<mailto:general-bounces at developer.marklogic.com> [mailto:general-bounces at developer.mar<mailto:general-bounces at developer.mar>klogic.com<http://klogic.com/>] Namens Randy Smith
Verzonden: donderdag 22 maart 2012 20:17
Aan: General MarkLogic Developer Discussion
Onderwerp: [MarkLogic Dev General] Corona Questions

All,
Trying to come up to speed with the Alpha version of Corona. i.e. the REST connection to MarkLogic.
BTW this is what I really need so thanks to the developer group!

I want to use it with a .NET app, i.e. send http queries, requests, etc and use the MarkLogic results in the .NET app.
Firs,t this is my view of how Corona works which may not be correct:
    - Http app server receives the REST message based on documentation rules i.e. server http address; service name; options etc... for the particular service.
    - Uses the library of apps to query or do whatever to the MarkLogic db it points to.
     - Packages the results and returns the results via Http to fulfill the request.

History of what I've done:
1. I've got Corona installed according to the instructions (I hope :-) ).
2. Ran the test/index.html test suite.
    - A lot of the tests run ok. Some do not. Not sure if this is because it is Alpha code or my error.
3. Pointed the http app server to the top-songs database we used in class as a test.
4. Note that the "setup" process added several Element Range Index to the database, i.e. rangeEl, fromPersonal, rangeKey, both string and decimal. Is this normal?
5. Almost everything I've tried from the .NET app or just adding the http call in a browser gives a 404 or 500 error.
    - For example:
        http//myhost:8011/kvquery?element=artist&value=Michael%20Jackson&contentType=xml

        http//myhost:8011/search?stringQuery=cat

        http//myhost:8011/store?uri=/songs/Air-Supply+The-One-That-You-Love.xml&contentType=xml


Any ideas on where to look to get Corona to begin to talk back to me?
Thanks,
Randy





_______________________________________________

General mailing list

General at developer.marklogic.com<mailto:General at developer.marklogic.com>

http://developer.marklogic.com/mailman/listinfo/general





_______________________________________________

General mailing list

General at developer.marklogic.com<mailto:General at developer.marklogic.com>

http://developer.marklogic.com/mailman/listinfo/general


_______________________________________________
General mailing list
General at developer.marklogic.com<mailto:General at developer.marklogic.com>
http://developer.marklogic.com/mailman/listinfo/general


_______________________________________________
General mailing list
General at developer.marklogic.com<mailto:General at developer.marklogic.com>
http://developer.marklogic.com/mailman/listinfo/general

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://developer.marklogic.com/pipermail/general/attachments/20120323/df49704e/attachment-0001.html 


More information about the General mailing list