[MarkLogic Dev General] Another Corona Question

Randy Smith randy.smith at msic.dia.mil
Wed Mar 28 14:03:49 PDT 2012


Thanks Scott!
That brought back an xml file but the result was empty. i.e.
*<corona:response>
<corona:meta>
<corona:start>0</corona:start>
<corona:end>0</corona:end>
<corona:total>0</corona:total>*
*<corona:executionTime>0.01</corona:executionTime>*
*</corona:meta>
<corona:results/>
</corona:response>*
We did get Corona to work on one database we had, but we have no idea 
why it worked on it and not on all of our other databases. Seems to be 
some issue like namespaces or some other.
Also, we are not able to store a file using Corona. The examples on the 
web are ok but they say all URIs have to begin with /folder/filename. I 
don't know what the "/" is relative to. Seems not to like 
c:/folder/filename.
Corona is just what we need but can't seem to get the complete handle on it.
Thanks,
Randy

On 3/28/2012 1:02 PM, Scott Stafford wrote:
> Instead of this...
> /search?stringQuery=cat?outputFormat=xml,
> Try this...
> /search?stringQuery=cat*&*outputFormat=xml
>
> Scott A. Stafford
>
> Consultant
> MarkLogic Corporation
> scott.stafford at marklogic.com <mailto:scott.stafford at marklogic.com>
> Cell:  +1 703-216-9459
> www.marklogic.com 
> <https://exchange.marklogic.com/owa/redir.aspx?C=a52921f13dcb409bbde5fd345ac431a6&URL=http%3a%2f%2fwww.marklogic.com%2f>
>
> This e-mail and any accompanying attachments are confidential. The 
> information is intended solely for the use of the individual to whom 
> it is addressed. Any review, disclosure, copying, distribution, or use 
> of this e-mail communication by others is strictly prohibited. If you 
> are not the intended recipient, please notify us immediately by 
> returning this message to the sender and delete all copies. Thank you 
> for your cooperation.
>
> ------------------------------------------------------------------------
> *From:* general-bounces at developer.marklogic.com 
> [general-bounces at developer.marklogic.com] On Behalf Of Randy Smith 
> [randy.smith at msic.dia.mil]
> *Sent:* Wednesday, March 28, 2012 12:05 PM
> *To:* General MarkLogic Developer Discussion
> *Subject:* [MarkLogic Dev General] Another Corona Question
>
> All,
> Still trying to get Corona working. In fact, we had a break through 
> and it seems to be working to some degree. The problem is that we can 
> point it to a database that has data (like the top-songs database we 
> used in class) but an empty result set is returned when using 
> something like...
>
> /*/search?stringQuery=cat?outputFormat=xml*/,
>
>  However, during our testing we did find one database where Corona 
> returned results. We were surprised.
> Question, what are things to look for when one database will not 
> return results and another will?
>     - Is it permissions? We don't think this is a problem.
>     - Is it related to namespaces?
>     - Is it related to encoding?
>     - Other?
>
> Any help appreciated.
> Randy
>
>
> _______________________________________________
> General mailing list
> General at developer.marklogic.com
> http://developer.marklogic.com/mailman/listinfo/general
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://developer.marklogic.com/pipermail/general/attachments/20120328/56f301d1/attachment.html 


More information about the General mailing list