[MarkLogic Dev General] xml ingestion quick question

cyanline llc info at cyanline.com
Tue Mar 24 09:43:48 PDT 2015


Dave,
   I've spent the past 3 weeks getting the app we've built in the 
app-builder iface, to be captured and re-deploy-able. We've got it 
working now, and I can deploy a new VM, a full rest application, and 
ingest the db content- all with the flick of a script. It was a lot of 
work but I am rather impressed with the results.
   The roxy documentation does do the trick, but the community can 
obviously always benefit from more write ups. I didn't do anything out 
of the ordinary, but was still considering doing a simple write up for 
capturing an ml app on one server, and deploying it to another server.
   Thank you for the tips!

-Cory
On 03/24/2015 09:23 AM, Dave Cassel wrote:
> Responding to the Roxy part of this -- check out Roxy's capture 
> functionality. Not well documented yet, but you can see the notes on 
> this GitHub ticket <https://github.com/marklogic/roxy/issues/304>.
>
> -- 
> Dave Cassel
> Developer Community Manager
> MarkLogic Corporation <http://www.marklogic.com/>
> Cell:  +1-484-798-8720
>
>
> From: David Ennis <david.ennis at hinttech.com 
> <mailto:david.ennis at hinttech.com>>
> Reply-To: MarkLogic Developer Discussion 
> <general at developer.marklogic.com <mailto:general at developer.marklogic.com>>
> Date: Tuesday, March 24, 2015 at 6:22 AM
> To: MarkLogic Developer Discussion <general at developer.marklogic.com 
> <mailto:general at developer.marklogic.com>>
> Subject: Re: [MarkLogic Dev General] xml ingestion quick question
>
>     I always find it more exact to configure my indexes in the admin
>     interface instead of the app-builder interface (I'm not a fan of
>     wizard-type things that hide some options).  You have more control
>     over the process and more options.
>
>
>     [BTW: when using roxy, we usually then read the database.xml and
>     extract the configured indexes for us in ml-config.xml later]
>
>
>
>     Kind Regards,
>     David Ennis
>
>
>     David Ennis
>     *Content Engineer*
>
>     HintTech <http://www.hinttech.com/>
>     Mastering the value of content
>     creative | technology | content
>
>     Delftechpark 37i
>     2628 XJ Delft
>     The Netherlands
>     T: +31 88 268 25 00
>     M: +31 63 091 72 80
>
>     http://www.hinttech.com <http://www.hinttech.com>[HintTech
>     Twitter] <https://twitter.com/HintTech>[HintTech Facebook]
>     <http://www.facebook.com/HintTech>[HintTech LinkedIn]
>     <http://www.linkedin.com/company/HintTech>
>
>     On 23 March 2015 at 20:50, cyanline llc <info at cyanline.com
>     <mailto:info at cyanline.com>> wrote:
>
>         Mike,
>            While attempting to add the Element via the "CONFIGURE
>         ELEMENT RANGE
>         INDEX" menu on the app builder interface (port 8000), upon
>         hitting the
>         "Find" button, I receive "No elements matched your search".
>         For this
>         app, I have added all the other Element Rage Indexes with this
>         method (~15).
>            I have not tried via the admin interface, nor with the
>         ml-config.xml
>         file.
>            The version of ML is 7.0-4.3
>
>         Thank you,
>         Cory
>         On 03/23/2015 03:44 PM, Michael Blakeley wrote:
>         > There is no nesting limit.
>         >
>         > Why can't you create an element-range index on
>         attachment_filename? Is there an error message?
>         >
>         > What's the full version number of the MarkLogic release
>         you're using?
>         >
>         > -- Mike
>         >
>         >> On 23 Mar 2015, at 11:27 , cyanline llc <info at cyanline.com
>         <mailto:info at cyanline.com>> wrote:
>         >>
>         >> Hello,
>         >>    What am I missing that I can create an Element Range
>         Index on
>         >> attachment-count but not attachment_filename?
>         >>    Below is sample XML that I am ingesting and building an
>         app around.
>         >>
>         >> <attachment-count>1</attachment-count>
>         >> <attachments>
>         >>    <attachment>
>         >> <attachment_filename>Adnserio~1.pdf</attachment_filename>
>         >>    </attachment>
>         >> </attachments>
>         >>
>         >>    I have checked and I am producing valid XML.
>         'attachment-count' is
>         >> obviously nested, so, is there a nesting maximum?
>         >>
>         >> Thanks in advance.
>         >> _______________________________________________
>         >> General mailing list
>         >> General at developer.marklogic.com
>         <mailto:General at developer.marklogic.com>
>         >> http://developer.marklogic.com/mailman/listinfo/general
>         >>
>         > _______________________________________________
>         > General mailing list
>         > General at developer.marklogic.com
>         <mailto:General at developer.marklogic.com>
>         > http://developer.marklogic.com/mailman/listinfo/general
>
>         _______________________________________________
>         General mailing list
>         General at developer.marklogic.com
>         <mailto:General at developer.marklogic.com>
>         http://developer.marklogic.com/mailman/listinfo/general
>
>
>
>
> _______________________________________________
> General mailing list
> General at developer.marklogic.com
> http://developer.marklogic.com/mailman/listinfo/general

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://developer.marklogic.com/pipermail/general/attachments/20150324/9a39566a/attachment-0001.html 


More information about the General mailing list