[MarkLogic Dev General] MarkLogic Upgrade from 6 to 8

Paul Hoehne Paul.Hoehne at marklogic.com
Wed Jan 27 08:48:24 PST 2016


This is what I would check first.  (Although I’ve never run into this specific problem).  Check to make sure that you meet the Linux/Unix guidelines in the install documents.  But usually Sasl is installed as part of the LDAP client libraries.  If you do have a version of libsasl present, and it’s the current version for your linux (maybe it’s libsasl2.so.3), you can symbolically link it to libsasl2.so.2.  Also, make sure you have the 64 bit version installed for 64 bit MarkLogic.

From: <general-bounces at developer.marklogic.com<mailto:general-bounces at developer.marklogic.com>> on behalf of "Khan, Kashif" <Kashif.Khan at hmhco.com<mailto:Kashif.Khan at hmhco.com>>
Reply-To: MarkLogic Developer Discussion <general at developer.marklogic.com<mailto:general at developer.marklogic.com>>
Date: Wednesday, January 27, 2016 at 11:38 AM
To: MarkLogic Developer Discussion <general at developer.marklogic.com<mailto:general at developer.marklogic.com>>
Subject: [MarkLogic Dev General] MarkLogic Upgrade from 6 to 8

Hello Everyone,

We just upgraded our MarkLogic server from version 6 to latest version 8. Now when we try to restart the MarkLogic server we are getting the following error. Does anyone know what is happening here.

Starting MarkLogic: /opt/MarkLogic/bin/MarkLogic: error while loading shared libraries: libsasl2.so.3: cannot open shared object file: No such file or directory


Best Regards,
Kashif Khan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://developer.marklogic.com/pipermail/general/attachments/20160127/210aba04/attachment.html 


More information about the General mailing list