[MarkLogic Dev General] Unable to set replica forest for data hub using gradle

David Ennis David.Ennis at marklogic.com
Tue Jan 23 14:59:40 PST 2018


I believe the forest replica names need to be unique. You use stage-forest-1-Replica twice.


Regards,

David Ennis

________________________________
From: general-bounces at developer.marklogic.com <general-bounces at developer.marklogic.com> on behalf of Vikas.Singh6 at cognizant.com <Vikas.Singh6 at cognizant.com>
Sent: 23 January 2018 18:22:10
To: general at developer.marklogic.com
Subject: [MarkLogic Dev General] Unable to set replica forest for data hub using gradle

Hi All,

We have 3 node cluster and want to set 8 forest (3,3,2) on 3 node cluster by using gradle . We decided to go with payload driven approach for configuring forest on each host as we want.
I am successfully able to configure forest on each host by using below payload.

Example: Payload with 2 forest only
[
 {
      “forest-name”:”stage-forest-1”,
       “host”:host1,
      “database”:test
   },
 {
      “forest-name”:”stage-forest-2”,
       “host”:host1,
      “database”:test
   }
]

Gradle mlDeploy command using perfectly  and setting forest on desired host.

Now I want to set replica of same forest must be created on different host so I changed my payload as below.
                                    [
 {
      “forest-name”:”stage-forest-1”,
       “host”:host1,
      “database”:test,
     “forest-replicas”:
       {
         “forest-replica”:
            [
             {
              “replica-name”:”stage-forest-1-Replica”,
               “host” : “host2”
              },
            {
              “replica-name”:”stage-forest-1-Replica”,
               “host” : “host3”
              }

            ]
        }
   }
]

Using same command gradle mlDeploy

For above pay load I am getting build failure as whenever I am trying to set up replica forest .
I am getting below message.

“MANAGE-CONFLICTINGCONFIG” : A conflict has been detected. A forest with the name stage-forest-1-Replica but different configuration exist.

Please guide me if I am doing anything wrong setting replica forest.

Thanks,
Vikas Singh
This e-mail and any files transmitted with it are for the sole use of the intended recipient(s) and may contain confidential and privileged information. If you are not the intended recipient(s), please reply to the sender and destroy all copies of the original message. Any unauthorized review, use, disclosure, dissemination, forwarding, printing or copying of this email, and/or any action taken in reliance on the contents of this e-mail is strictly prohibited and may be unlawful. Where permitted by applicable law, this e-mail and other e-mail communications sent to and from Cognizant e-mail addresses may be monitored.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://developer.marklogic.com/pipermail/general/attachments/20180123/694af9d8/attachment.html 


More information about the General mailing list