<html><head></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">I know at one point Corona only knew about docs inserted via Corona, but I believe that behavior has changed. &nbsp;Hm…<div><br></div><div>E</div><div><br><div apple-content-edited="true"><span class="Apple-style-span" style="border-collapse: separate; color: rgb(0, 0, 0); font-family: Helvetica; font-size: medium; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; orphans: 2; text-align: auto; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-border-horizontal-spacing: 0px; -webkit-border-vertical-spacing: 0px; -webkit-text-decorations-in-effect: none; -webkit-text-size-adjust: auto; -webkit-text-stroke-width: 0px; "><div><br></div></span><br class="Apple-interchange-newline">
</div>
<br><div><div>On Mar 23, 2012, at 9:25 AM, Randy Smith wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite">

  
    <meta content="text/html; charset=windows-1252" http-equiv="Content-Type">
    <title></title>
  
  <div bgcolor="#ffffff" text="#000000">
    Geert,<br>
    I ran the CQ search you suggested and lots of results came back for
    'cat'. I am puzzled why it is not working. I even created a new
    version of the top-songs database which worked fine with CQ but with
    no results when running the Corona test. <br>
    <br>
    I looked over the installation but did not see any problem. I wonder
    if there could be a permission problem. Are the two Corona accounts
    that were created when Corona was setup involved when running
    Corona? I am currently running as admin when I run my tests.<br>
    Thanks for the help so far.<br>
    Ideas?<br>
    Randy<br>
    <br>
    On 3/23/2012 1:36 AM, Geert Josten wrote:
    <blockquote cite="mid:ad2ef634e4a13f99f24bab8b42cb0070@mail.gmail.com" type="cite">
      <meta http-equiv="Content-Type" content="text/html;
        charset=windows-1252">
      <meta name="Generator" content="Microsoft Word 14 (filtered
        medium)">
      <style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
@font-face
        {font-family:Consolas;
        panose-1:2 11 6 9 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";
        color:black;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
code
        {mso-style-priority:99;
        font-family:"Courier New";}
pre
        {mso-style-priority:99;
        mso-style-link:"HTML - vooraf opgemaakt Char";
        margin:0cm;
        margin-bottom:.0001pt;
        font-size:10.0pt;
        font-family:"Courier New";
        color:black;}
p.MsoAcetate, li.MsoAcetate, div.MsoAcetate
        {mso-style-priority:99;
        mso-style-link:"Ballontekst Char";
        margin:0cm;
        margin-bottom:.0001pt;
        font-size:8.0pt;
        font-family:"Tahoma","sans-serif";
        color:black;}
span.HTML-voorafopgemaaktChar
        {mso-style-name:"HTML - vooraf opgemaakt Char";
        mso-style-priority:99;
        mso-style-link:"HTML - vooraf opgemaakt";
        font-family:Consolas;
        color:black;}
span.BallontekstChar
        {mso-style-name:"Ballontekst Char";
        mso-style-priority:99;
        mso-style-link:Ballontekst;
        font-family:"Tahoma","sans-serif";
        color:black;}
span.E-mailStijl22
        {mso-style-type:personal;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
span.E-mailStijl23
        {mso-style-type:personal;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
span.E-mailStijl24
        {mso-style-type:personal-reply;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:70.85pt 70.85pt 70.85pt 70.85pt;}
div.WordSection1
        {page:WordSection1;}
--></style>
      <div class="WordSection1"><p class="MsoNormal"><span style="font-size: 11pt; font-family:
            &quot;Calibri&quot;,&quot;sans-serif&quot;; color: rgb(31,
            73, 125);" lang="EN-US">Hi Randy,</span></p><div><span style="font-size: 11pt; font-family:
            &quot;Calibri&quot;,&quot;sans-serif&quot;; color: rgb(31,
            73, 125);" lang="EN-US">&nbsp;</span><br class="webkit-block-placeholder"></div><p class="MsoNormal"><span style="font-size: 11pt; font-family:
            &quot;Calibri&quot;,&quot;sans-serif&quot;; color: rgb(31,
            73, 125);" lang="EN-US">The reason I asked is because you
            aren’t getting back results. That sounds either that there
            really aren’t any docs containing the word ‘cat’ (less
            likely I thought), or you are running against an empty
            database. Did you double check? You could also run a test
            query in Query Console (or CQ if you are using ML 4) to make
            sure, with something like:</span></p><div><span style="font-size: 11pt; font-family:
            &quot;Calibri&quot;,&quot;sans-serif&quot;; color: rgb(31,
            73, 125);" lang="EN-US">&nbsp;</span><br class="webkit-block-placeholder"></div><p class="MsoNormal" style="text-indent: 35.4pt;"><span style="font-size: 11pt; font-family:
            &quot;Calibri&quot;,&quot;sans-serif&quot;; color: rgb(31,
            73, 125);" lang="EN-US">cts:search(collection(), ‘cat’)</span></p><div><span style="font-size: 11pt; font-family:
            &quot;Calibri&quot;,&quot;sans-serif&quot;; color: rgb(31,
            73, 125);" lang="EN-US">&nbsp;</span><br class="webkit-block-placeholder"></div><p class="MsoNormal"><span style="font-size: 11pt; font-family:
            &quot;Calibri&quot;,&quot;sans-serif&quot;; color: rgb(31,
            73, 125);" lang="EN-US">(and selecting the correct database
            in the console of course..)</span></p><div><span style="font-size: 11pt; font-family:
            &quot;Calibri&quot;,&quot;sans-serif&quot;; color: rgb(31,
            73, 125);" lang="EN-US">&nbsp;</span><br class="webkit-block-placeholder"></div><p class="MsoNormal"><span style="font-size: 11pt; font-family:
            &quot;Calibri&quot;,&quot;sans-serif&quot;; color: rgb(31,
            73, 125);" lang="EN-US">Kind regards,</span></p><p class="MsoNormal"><span style="font-size: 11pt; font-family:
            &quot;Calibri&quot;,&quot;sans-serif&quot;; color: rgb(31,
            73, 125);" lang="EN-US">Geert</span></p><div><span style="font-size: 11pt; font-family:
            &quot;Calibri&quot;,&quot;sans-serif&quot;; color: rgb(31,
            73, 125);" lang="EN-US">&nbsp;</span><br class="webkit-block-placeholder"></div>
        <div style="border-width: medium medium medium 1.5pt;
          border-style: none none none solid; border-color:
          -moz-use-text-color -moz-use-text-color -moz-use-text-color
          blue; padding: 0cm 0cm 0cm 4pt;">
          <div>
            <div style="border-right: medium none; border-width: 1pt
              medium medium; border-style: solid none none;
              border-color: rgb(181, 196, 223) -moz-use-text-color
              -moz-use-text-color; padding: 3pt 0cm 0cm;"><p class="MsoNormal"><b><span style="font-size: 10pt;
                    font-family:
                    &quot;Tahoma&quot;,&quot;sans-serif&quot;; color:
                    windowtext;">Van:</span></b><span style="font-size:
                  10pt; font-family:
                  &quot;Tahoma&quot;,&quot;sans-serif&quot;; color:
                  windowtext;"> <a moz-do-not-send="true" href="mailto:general-bounces@developer.marklogic.com">general-bounces@developer.marklogic.com</a>
                  [mailto:<a moz-do-not-send="true" href="mailto:general-bounces@developer.marklogic.com">general-bounces@developer.marklogic.com</a>]
                  <b>Namens </b>Randy Smith<br>
                  <b>Verzonden:</b> donderdag 22 maart 2012 22:38<br>
                  <b>Aan:</b> MarkLogic Developer Discussion<br>
                  <b>Onderwerp:</b> Re: [MarkLogic Dev General] Corona
                  Questions</span></p>
            </div>
          </div><div>&nbsp;<br class="webkit-block-placeholder"></div><p class="MsoNormal">
            Geert,<br>
            Eric is correct, I point it to the top-songs database we
            used in class. My app we did in class works against the same
            database so it should be ok. You said something about the
            config of Corona. I have not touched that. Is that a place
            to look for issues?<br>
            Randy<br>
            <br>
            On 3/22/2012 4:18 PM, Geert Josten wrote: </p><p class="MsoNormal"><span style="font-size: 11pt;
              font-family: &quot;Calibri&quot;,&quot;sans-serif&quot;;">Hi
              Randy,</span></p><div><span style="font-size: 11pt;
              font-family: &quot;Calibri&quot;,&quot;sans-serif&quot;;">&nbsp;</span><br class="webkit-block-placeholder"></div><p class="MsoNormal"><span style="font-size: 11pt;
              font-family: &quot;Calibri&quot;,&quot;sans-serif&quot;;" lang="EN-US">Are you sure corona is running against the
              correct documents database? Your rest call works just fine
              with me, returning proper results..</span></p><div><span style="font-size: 11pt;
              font-family: &quot;Calibri&quot;,&quot;sans-serif&quot;;" lang="EN-US">&nbsp;</span><br class="webkit-block-placeholder"></div><p class="MsoNormal"><span style="font-size: 11pt;
              font-family: &quot;Calibri&quot;,&quot;sans-serif&quot;;" lang="EN-US">Kind regards,</span></p><p class="MsoNormal"><span style="font-size: 11pt;
              font-family: &quot;Calibri&quot;,&quot;sans-serif&quot;;" lang="EN-US">Geert</span></p><div><span style="font-size: 11pt;
              font-family: &quot;Calibri&quot;,&quot;sans-serif&quot;;" lang="EN-US">&nbsp;</span><br class="webkit-block-placeholder"></div>
          <div style="border-width: medium medium medium 1.5pt;
            border-style: none none none solid; padding: 0cm 0cm 0cm
            4pt; border-color: -moz-use-text-color -moz-use-text-color
            -moz-use-text-color blue;">
            <div>
              <div style="border-right: medium none; border-width: 1pt
                medium medium; border-style: solid none none; padding:
                3pt 0cm 0cm; border-color: -moz-use-text-color;"><p class="MsoNormal"><b><span style="font-size: 10pt;
                      font-family:
                      &quot;Tahoma&quot;,&quot;sans-serif&quot;; color:
                      windowtext;">Van:</span></b><span style="font-size: 10pt; font-family:
                    &quot;Tahoma&quot;,&quot;sans-serif&quot;; color:
                    windowtext;"> <a moz-do-not-send="true" href="mailto:general-bounces@developer.marklogic.com">general-bounces@developer.marklogic.com</a>
                    [mailto:<a moz-do-not-send="true" href="mailto:general-bounces@developer.marklogic.com">general-bounces@developer.marklogic.com</a>]
                    <b>Namens </b>Randy Smith<br>
                    <b>Verzonden:</b> donderdag 22 maart 2012 22:01<br>
                    <b>Aan:</b> MarkLogic Developer Discussion<br>
                    <b>Onderwerp:</b> Re: [MarkLogic Dev General] Corona
                    Questions</span></p>
              </div>
            </div><div>&nbsp;<br class="webkit-block-placeholder"></div><p class="MsoNormal">
              Geert,<br>
              I'm running the latest copy (a few days old).<br>
              <br>
              &nbsp;I just found that when I do&nbsp;<code><span style="font-size:
                  10pt;">
                  http//myhost:8011/search?stringQuery=cat&amp;outputFormat=xml&nbsp;</span></code>
              I now get back an xml file in the search results format&nbsp;
              indicated in the documentation. That has got to be a good
              sign!!! :-) The only problem is that the "results" tag is
              empty. The meta tag also comes back but has all zeros.<br>
              This is the xml file as it comes back in the browser:<br>
              <b><br>
                &lt;corona:response&gt;<br>
                &nbsp;&nbsp;&nbsp; &lt;corona:meta&gt;<br>
                &nbsp; &nbsp;&nbsp;&nbsp; &nbsp; &lt;corona:start&gt;0&lt;/corona:start&gt;<br>
                &nbsp; &nbsp;&nbsp;&nbsp; &nbsp; &lt;corona:end&gt;0&lt;/corona:end&gt;<br>
                &nbsp;&nbsp; &nbsp;&nbsp; &nbsp; &lt;corona:total&gt;0&lt;/corona:total&gt;</b><br>
              <b>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;
                &lt;corona:executionTime&gt;0S&lt;/corona:executionTime&gt;</b><br>
              <b>&nbsp;&nbsp;&nbsp; &lt;/corona:meta&gt;<br>
                &nbsp;&nbsp;&nbsp; &lt;corona:results/&gt;<br>
                &lt;/corona:response&gt;</b><br>
              <br>
              Note that the executionTime comes back with something like
              .01 if I leave off the "outputFormat=xml. So, that works
              if it thinks it is JSON.<br>
              <br>
              Hope this offers some clues!<br>
              Thanks for the help!<br>
              Randy<br>
              On 3/22/2012 3:23 PM, Geert Josten wrote: </p><p class="MsoNormal"><span style="font-size: 11pt;
                font-family:
                &quot;Calibri&quot;,&quot;sans-serif&quot;;" lang="EN-US">Hi Randy,</span></p><div><span style="font-size: 11pt;
                font-family:
                &quot;Calibri&quot;,&quot;sans-serif&quot;;" lang="EN-US">&nbsp;</span><br class="webkit-block-placeholder"></div><p class="MsoNormal"><span style="font-size: 11pt;
                font-family:
                &quot;Calibri&quot;,&quot;sans-serif&quot;;" lang="EN-US">A 404 likely means the endpoints config is
                wonky. Are you running latest copy from git? The 500
                indicates something goes wrong internally. Can you tell
                what response you are getting exactly? In case of a 500,
                there should be more details in the response body.</span></p><div><span style="font-size: 11pt;
                font-family:
                &quot;Calibri&quot;,&quot;sans-serif&quot;;" lang="EN-US">&nbsp;</span><br class="webkit-block-placeholder"></div><p class="MsoNormal"><span style="font-size: 11pt;
                font-family:
                &quot;Calibri&quot;,&quot;sans-serif&quot;;" lang="EN-US">Kind regards,</span></p><p class="MsoNormal"><span style="font-size: 11pt;
                font-family:
                &quot;Calibri&quot;,&quot;sans-serif&quot;;" lang="EN-US">Geert</span></p><div><span style="font-size: 11pt;
                font-family:
                &quot;Calibri&quot;,&quot;sans-serif&quot;;" lang="EN-US">&nbsp;</span><br class="webkit-block-placeholder"></div>
            <div style="border-width: medium medium medium 1.5pt;
              border-style: none none none solid; padding: 0cm 0cm 0cm
              4pt; border-color: -moz-use-text-color -moz-use-text-color
              -moz-use-text-color blue;">
              <div>
                <div style="border-right: medium none; border-width: 1pt
                  medium medium; border-style: solid none none; padding:
                  3pt 0cm 0cm; border-color: -moz-use-text-color;"><p class="MsoNormal"><b><span style="font-size: 10pt;
                        font-family:
                        &quot;Tahoma&quot;,&quot;sans-serif&quot;;
                        color: windowtext;" lang="EN-US">Van:</span></b><span style="font-size: 10pt; font-family:
                      &quot;Tahoma&quot;,&quot;sans-serif&quot;; color:
                      windowtext;" lang="EN-US"> <a moz-do-not-send="true" href="mailto:general-bounces@developer.marklogic.com">general-bounces@developer.marklogic.com</a>
                      [mailto:<a moz-do-not-send="true" href="mailto:general-bounces@developer.mar">general-bounces@developer.mar</a></span><span style="font-size: 10pt; font-family:
                      &quot;Tahoma&quot;,&quot;sans-serif&quot;; color:
                      windowtext;"><a moz-do-not-send="true" href="http://klogic.com/">klogic.com</a>] <b>Namens
                      </b>Randy Smith<br>
                      <b>Verzonden:</b> donderdag 22 maart 2012 20:17<br>
                      <b>Aan:</b> General MarkLogic Developer Discussion<br>
                      <b>Onderwerp:</b> [MarkLogic Dev General] Corona
                      Questions</span></p>
                </div>
              </div><div>&nbsp;<br class="webkit-block-placeholder"></div><p class="MsoNormal" style="margin-bottom: 12pt;">
                All,<br>
                Trying to come up to speed with the Alpha version of
                Corona. i.e. the REST connection to MarkLogic.<br>
                <b>BTW this is what I really need so thanks to the
                  developer group!</b><br>
                <br>
                I want to use it with a .NET app, i.e. send http
                queries, requests, etc and use the MarkLogic results in
                the .NET app.<br>
                Firs,t this is my view of how Corona works which may not
                be correct:<br>
                &nbsp;&nbsp;&nbsp; - Http app server receives the REST message based on
                documentation rules i.e. server http address; service
                name; options etc... for the particular service.<br>
                &nbsp;&nbsp;&nbsp; - Uses the library of apps to query or do whatever
                to the MarkLogic db it points to.<br>
                &nbsp;&nbsp;&nbsp;&nbsp; - Packages the results and returns the results via
                Http to fulfill the request.<br>
                <br>
                History of what I've done:<br>
                1. I've got Corona installed according to the
                instructions (I hope :-) ).<br>
                2. Ran the test/index.html test suite.<br>
                &nbsp;&nbsp;&nbsp; - A lot of the tests run ok. Some do not. Not sure
                if this is because it is Alpha code or my error.<br>
                3. Pointed the http app server to the top-songs database
                we used in class as a test.<br>
                4. Note that the "setup" process added several Element
                Range Index to the database, i.e. rangeEl, fromPersonal,
                rangeKey, both string and decimal.<b><u> Is this normal?</u></b><br>
                5. Almost everything I've tried from the .NET app or
                just adding the http call in a browser gives a 404 or
                500 error.<br>
                &nbsp;&nbsp;&nbsp; - <code><span style="font-size: 10pt;">For example:</span></code><span style="font-size: 10pt; font-family: &quot;Courier
                  New&quot;;"><br>
                  <code>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;
http//myhost:8011/kvquery?element=artist&amp;value=Michael%20Jackson&amp;contentType=xml</code><br>
                  <br>
                  <code>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; http//myhost:8011/search?stringQuery=cat</code><br>
                  <br>
                  <code>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;
http//myhost:8011/store?uri=/songs/Air-Supply+The-One-That-You-Love.xml&amp;contentType=xml</code></span><br>
                <br>
                <br>
                Any ideas on where to look to get Corona to begin to
                talk back to me?<br>
                Thanks,<br>
                Randy</p>
            </div>
            <pre>&nbsp;</pre>
            <pre>&nbsp;</pre>
            <pre>_______________________________________________</pre>
            <pre>General mailing list</pre>
            <pre><a moz-do-not-send="true" href="mailto:General@developer.marklogic.com">General@developer.marklogic.com</a></pre>
            <pre><a moz-do-not-send="true" href="http://developer.marklogic.com/mailman/listinfo/general">http://developer.marklogic.com/mailman/listinfo/general</a></pre>
          </div>
          <pre>&nbsp;</pre>
          <pre>&nbsp;</pre>
          <pre>_______________________________________________</pre>
          <pre>General mailing list</pre>
          <pre><a moz-do-not-send="true" href="mailto:General@developer.marklogic.com">General@developer.marklogic.com</a></pre>
          <pre><a moz-do-not-send="true" href="http://developer.marklogic.com/mailman/listinfo/general">http://developer.marklogic.com/mailman/listinfo/general</a></pre>
        </div>
      </div>
      <pre wrap=""><fieldset class="mimeAttachmentHeader"></fieldset>
_______________________________________________
General mailing list
<a class="moz-txt-link-abbreviated" href="mailto:General@developer.marklogic.com">General@developer.marklogic.com</a>
<a class="moz-txt-link-freetext" href="http://developer.marklogic.com/mailman/listinfo/general">http://developer.marklogic.com/mailman/listinfo/general</a>
</pre>
    </blockquote>
  </div>

_______________________________________________<br>General mailing list<br><a href="mailto:General@developer.marklogic.com">General@developer.marklogic.com</a><br>http://developer.marklogic.com/mailman/listinfo/general<br></blockquote></div><br></div></body></html>