[MarkLogic Dev General] xhtml loading question

Devadoss P devadossp at gmail.com
Tue Aug 14 13:33:11 PDT 2007


James and Mike,

How to resolve (xmlns="http://www.w3.org/1999/xhtml") namespace conflict in
xquery; I loaded html document (which has xmlns namespce defined) to
MarkLogic and tried to query its element by using cts:search(), but it
returns empty row.

Can you help me to resolve namespace issue?

Thanks,
Dev


On 8/14/07, Alex Rice <alexr at santafe.edu> wrote:
>
> James and Michael:
>
> i had not even thought of namespaces. now I am getting nodes back and
> can use the declare namespace feature etc. Thank you both for
> responding.
>
> Alex Rice
>
>
> On 8/14/07, James Clippinger <James.Clippinger at marklogic.com> wrote:
> > Alex, I'm not familiar with the XHTML created by Dreamweaver or UpCast,
> > but I suspect the XHTML elements both tools create are in the XHTML
> > namespace.  Try this (keeping in mind the wildcard-namespace syntax may
> > be slow):
> >
> > doc("/SFI/Update/news/articletest2/test.xml")//*:p
> >
> > If it returns items, you can see which namespace each item is in and go
> > from there.
> >
> > Regards,
> > James
> >
> _______________________________________________
> General mailing list
> General at developer.marklogic.com
> http://xqzone.com/mailman/listinfo/general
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://xqzone.marklogic.com/pipermail/general/attachments/20070814/2ccb9a9f/attachment.html


More information about the General mailing list