[MarkLogic Dev General] XCC/J API compiled against Java 6.0?

Charles Greer cgreer at marklogic.com
Tue Oct 15 10:35:31 PDT 2013


Hi Aaron

According to this page: http://developer.marklogic.com/products/java, 
the Java API does require Java 6 or later.

Charles


On 10/14/2013 03:55 PM, aaron.korver at thomsonreuters.com wrote:
>
> Hi all,
>
> It looks like the 6.0.3 version of the Java API has been compiled 
> against Java 6.0.  When I run javap --verbose against a .class file in 
> the jar, I see the following.  "major version: 50"  This means a 6.0 
> JDK compiled it.  This is a problem, since the project I'm on that is 
> using is currently restricted to using the Java 5 JDK.  So...is JDK 6 
> now a requirement, or was this just compiled incorrectly?
>
> Thank you,
>
> Aaron Korver
>
>
>
> _______________________________________________
> General mailing list
> General at developer.marklogic.com
> http://developer.marklogic.com/mailman/listinfo/general

-- 
Charles Greer
Senior Engineer
MarkLogic Corporation
charles.greer at marklogic.com
Phone: +1 707 408 3277
www.marklogic.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://developer.marklogic.com/pipermail/general/attachments/20131015/6032403e/attachment.html 


More information about the General mailing list