The tables below display platform and software configurations that are eligible for support under our subscription offerings. Learn more about our Support Handbook.

Don’t see your favorite platform, JVM, or browser? Contact us.

Please refer to your operating system documentation for more details.


MarkLogic Core Database (Server)

Operating Systems

  MarkLogic 9 MarkLogic 10
RHEL 7 Supported Supported
RHEL 8 Supported Supported
CentOS 7 (x64) Supported Supported
CentOS 8 (x64) Supported Supported
Windows 10 64-bit (x64) Supported Supported
Windows Server 2012 (x64) Supported Supported
Windows Server 2016 Supported Supported
Windows Server 2019 Not Supported Supported
Mac OSX 10.14* Supported Supported

*Only for development

*Not supported on ARM architecture

Containers

  MarkLogic 9 MarkLogic 10
Docker on RedHat 7.4 Supported Supported
Docker Hub* Supported Supported

*Only for development

VMWare(RHEL running on VMWare)

  MarkLogic 9 MarkLogic 10
ESXi 6.0 Supported Not Supported
ESXi 6.7 Not Supported Supported

Supported Browsers

  MarkLogic 9 MarkLogic 10
IE9 & Edge Not Supported Not Supported
IE11+ Supported Supported
Firefox Supported Not Supported
Chrome Supported Supported
Edge Chromium Not Supported Not Supported

Filesystems

Operating System Supported Filesystem MarkLogic 9 MarkLogic 10
Linux
  • XFS (recommended)
  • EXT3
  • EXT4
  • Clustered filesystems (see below)
Supported Supported
Windows NTFS Supported Supported
Mac OS HFS+ Supported Supported
All Amazon S3* Supported Supported

*No journaling with S3

Veritas CFS

  MarkLogic 9 MarkLogic 10
VxFS6.2 Supported Supported
VxFS7.3 Not Supported  Supported

GFS

  MarkLogic 9 MarkLogic 10
RHEL 7 +GFS2 Supported Supported

NAS

  MarkLogic 9 MarkLogic 10
RHEL 7 + NetAPP Supported Supported

HDFS

  MarkLogic 9.0-1 to 9.0-8 MarkLogic 9.0-9* MarkLogic 10*
CDH 5.4 Supported Supported Supported
CDH 5.8 Supported Supported Supported
HDP 2.4** Supported Supported Not Supported
MapR 5.1 (MapR-FS)** Supported Not Supported Not Supported
HDP2.6** Supported Supported Not Supported

*ML 9: For versions 9.0-12 and newer, HDFS has been deprecated.

*ML 10: For versions 10.0-3 and newer, HDFS has been deprecated.

**Product has reached end of support by vendor

Hadoop connector / MLCP distributed mode (map reduce framework support)

  MarkLogic 9* MarkLogic 10*
CDH 5.4 Supported Supported Supported
CDH 5.8 Supported Supported Supported
HDP 2.4** Supported Supported Not Supported
MapR 5.1 (MapR-FS)** Supported Not Supported Not Supported
HDP2.6** Supported Supported Not Supported

*ML 9: For versions 9.0-12 and newer, HDFS has been deprecated.

*ML 10: For versions 10.0-3 and newer, HDFS has been deprecated.

**Product has reached end of support by vendor

EC2

  MarkLogic 9 MarkLogic 10
Amazon Linux 1 Supported Not Supported
Amazon Linux 2 Supported Supported

Java Virtual Machines

  MarkLogic 9 MarkLogic 10
Oracle/Sun Supported Supported
OpenJDK Supported Supported
IBM JRE Not Supported Not Supported

Java Virtual Machine Requirements

MarkLogic Server can function with or without a Java Virtual Machine (JVM). The only requirement needed for a JVM to be installed on MarkLogic Server would be if you use HDFS (Hadoop Distributed File System).

Our provided Amazon AMIs have a JDK pre-installed that is used during the MarkLogic bootstrap process to setup and configure MarkLogic in the Amazon environment. Therefore, you do not need to install a JVM on any EC2 instance.

Java

MarkLogic 9.0-1 to 9.0-8 MarkLogic 9.0-9 and beyond MarkLogic 10
Java 7 Not Supported Supported Not Supported
Java 8 Supported Supported Supported
Java 9 Not Supported Supported Supported
Java 10 Not Supported Supported Supported
Java 11 Not Supported Supported Supported

 


MarkLogic Data Hub

Server Version Compatibility

The following MarkLogic Server versions are supported for various Data Hub and Data Hub Framework versions.

  Data Hub / Data Hub Framework version MarkLogic 9 MarkLogic 10
5 5.6.x 9.0-11.0 up to the latest 9.x release 10.0-2.1 up to the latest 10.x release

Note: 10.0-3 or later is required for the more granular security roles introduced in Data Hub 5.2.0.

5.5.x 9.0-11.0 up to the latest 9.x release 10.0-2.1 up to the latest 10.x release

Note: 10.0-3 or later is required for the more granular security roles introduced in Data Hub 5.2.0.

5.4.x 9.0-11.0 up to the latest 9.x release 10.0-2.1 up to the latest 10.x release

Note: 10.0-3 or later is required for the more granular security roles introduced in Data Hub 5.2.0.

5.2.x 9.0-10.3 up to the latest 9.x release 10.0-2.1 up to the latest 10.x release

Note: 10.0-3 or later is required for the more granular security roles introduced in Data Hub 5.2.0.

5.1.x 9.0-10.3 up to the latest 9.x release 10.0-2.1 up to the latest 10.x release
5.0.x 9.0-10.3 up to the latest 9.x release 10.0-2.1 up to the latest 10.x release
4 4.3.2 9.0-7 up to the latest 9.x release Not Supported
4.3.1 9.0-6 to 9.0-9 Not Supported
4.2.x 9.0-6 to 9.0-9 Not Supported
4.1.x 9.0-5 to 9.0-9 Not Supported
4.0.x 9.0-5 to 9.0-9 Not Supported

Supported Browsers

  Quickstart Hub Central
IE 9  & EDGE Not Supported Not Supported
IE 11+ Not Supported Not Supported
Firefox Supported Supported
Chrome Supported Supported
Edge Chromium Supported Supported

Java Virtual Machines

MarkLogic Data Hub Framework requires a JVM to either run or install

  MarkLogic 9 MarkLogic 10
Oracle/Sun Supported Supported
OpenJDK Supported Supported
IBM JRE Not Supported Not Supported

Java

  Data Hub / Data Hub Framework version Supported Java Versions
5 5.6.x Java 8-11
5.5.x Java 8-11
5.4.x Java 8-11
5.3.x Java 8-11
5.2.x Java 8-11
5.1.x Java 8-11
5.0.x Java 8-11
4 4.3.2 Java 8 minimum
4.3.1 Java 8 minimum
4.2.x Java 8 minimum
4.1.x Java 8 minimum
4.0.x Java 8 minimum

Gradle

  Data Hub / Data Hub Framework version Minimum Supported Gradle Version
5 5.6.x 6.4
5.5.x 6.4
5.4.x 6.4
5.2.x 4.6
5.1.x 4.6
5.0.x 4.6
4 4.3.2 3.4
4.3.1 3.4
4.2.x 3.4
4.1.x 3.4
4.0.x 3.4

Dependencies 

Software Minimum Supported Version
Java JRE (OpenJDK) 8
MarkLogic Server See Marklogic Core Database (Server) Tab
Gradle 6.4

*Internet Connectivity Required


MarkLogic Data Hub Service

Cloud Version Compatibility 

Data Hub Version Server Version
AWS 3.2 5.5.5 10.0-8
AWS 3.1 5.5.2 10.0-7.1
AWS 3.0 5.4.4 10.0-6.1
AWS 2.11 5.2.6 10.0-6.1
Azure 1.1 5.2.6 10.0-6.1
Azure 1.0 5.2.1 10.0-4

ML-Gradle

Requirements

  • Java 8 or later
  • MarkLogic 9 or 10

Java Virtual Machines

Gradle requires a JVM to either run or install

MarkLogic 9 MarkLogic 10
Oracle/Sun Supported Supported
OpenJDK Supported Supported
IBM JRE Not Supported Not Supported

Java

MarkLogic 9.0-1 to 9.0-8 MarkLogic 9.0-9 and beyond MarkLogic 10
Java 8 Supported Supported Supported
Java 9 Not Supported Supported Supported
Java 10 Not Supported Supported Supported
Java 11 Not Supported Supported Supported

 


MLCP/XCC

Unless otherwise noted, MLCP is compatible with a wide range of MarkLogic versions. That is, you can usually use a recent version of MLCP with an older version of MarkLogic and vice versa. However, not all features of MLCP or MarkLogic will work across version boundaries.

For best results, use the version of MLCP that corresponds to your version of MarkLogic, or limit your jobs to features you know are supported in both. For specific MLCP/XCC versions released at time of server version release, see compatibility table below.

Required Software

  • MarkLogic Server
  • Oracle/Sun Java JRE 1.8 or later

ODBC Driver

The ODBC driver is both forward and backward compatible. However, for full access to feature offering, the newest version of MarkLogic and ODBC driver is recommended. For specific ODBC versions released at time of server version release, see compatibility table below.


Node.js Client API

The Node.js client API is backwards compatible. However, for full access to feature offering, the newest version of Marklogic and the Node.js client API is recommended. For specific Node.js versions release at the time of server version release, see compatibility table below.

Required Software

  • MarkLogic 9 or later
  • Node.js version (see below)
  • The Node.js Package Manager tool, npm. The latest version compatible with a supported Node.js version is recommended.
  • If you plan to use Kerberos for authentication, you must have the MIT Kerberos software. For details, see Using Kerberos Authentication.
  Node.js Client API Version
Node Version 2.0.2 2.0.3 2.1.1 2.2.0 2.3.0 2.3.1 2.3.2 2.4.0 2.4.1 2.4.2 2.5.0 2.6.0 2.7.0
Node 14 Supported Supported Supported Supported Supported Supported Supported Supported Supported Supported Supported Supported Supported
Node 16 Supported Supported Supported Supported Supported Supported Supported Supported Supported Supported Supported Supported Supported

 


Java Client API

The Java client API is backwards compatible. However, for full access to feature offering, the newest version of MarkLogic and the Java client API is recommended. For specific Java versions released at the time of server version release, see compatibility table below.

Required Software

The Java Client API is supported on the same platforms as MarkLogic Server (See above)

The Java Client API requires the following software:

  • MarkLogic 9 or 10
  • Oracle/Sun Java Runtime Environment (JRE) 1.8 or later

Compatible Versions at Time of Server Releases

ML Server Release MLCP Version ODBC version Java Client API Version Node Client API Version
9.0-1 9.0.1 1.3-1 4.0.0 2.0.2
9.0-2 9.0.2 1.3-2 4.0.2 2.0.3
9.0-3 9.0.3 1.3-3 4.0.2 2.0.3
9.0-3.1 9.0.3 1.3-3 4.0.2 2.0.3
9.0-4 9.0.4 1.3-4 4.0.2 2.0.3
9.0-4.1 9.0.4 13-4 4.0.2 2.0.3
9.0-4.2 9.0.4 1.3-4 4.0.2 2.0.3
9.0-4.3 9.0.4 1.3-4 4.0.2 2.0.3
9.0-5 9.0.5 1.3-5 4.0.4 2.1.1
9.0-5.1 9.0.5 1.3-5 4.0.4 2.1.1
9.0-6 9.0.6 1.3-6 4.1.0 2.1.1
9.0-6.1 9.0.6 1.3-6 4.1.0 2.1.1
9.0-7 9.0.7 1.3-7 4.1.1 2.1.1
9.0-7.1 9.0.7 1.3-7 4.1.1 2.1.1
9.0-7.2 9.0.7.2 1.3-7 4.1.1 2.1.1
9.0-7.3 9.0.7.2 1.3-7 4.1.1 2.1.1
9.0-8 9.0.8 1.3-8 4.1.1 2.1.1
9.0-8.1 9.0.8 1.3-8 4.1.1 2.1.1
9.0-8.2 9.0.8 1.3-8 4.1.2 2.1.1
9.0-9 9.0.9 1.3-9 4.2.0 2.1.1
9.0-9.1 9.0.9 1.3-9.1 4.2.0 2.2.0
9.0-9.2 9.0.9 1.3-9.1 4.2.0 2.2.0
9.0-9.3 9.0.9 1.3-9.1 4.2.0 2.1.1
9.0-9.4 9.0.9 1.3-9.1 4.2.0 2.1.1
9.0-9.5 9.0.9 1.3-9.1 4.2.0 2.1.1
9.0-10 9.0.10 1.3-10 5.0.1 2.3.0
9.0-10.1 9.0.10 1.3-10 5.0.1 2.3.0
9.0-10.2 9.0.10.2 1.3-10 5.0.1 2.4.0
9.0-10.3 9.0.10.2 1.3-10 5.0.1 2.4.0
9.0-10.4 9.0.10.2 1.3-10 5.0.0 2.4.0
9.0-10.5 9.0.10.2 1.3-10 5.0.1 2.4.0
9.0-11 9.0.11 1.3-11 5.0.1 2.4.0
9.0-12 9.0.12 1.3-12 5.1.0 2.4.0
9.0-12.1 9.0.12 1.3-12 5.2.0 2.4.1
9.0-12.1 9.0.12 1.3-12 5.2.0 2.4.1
9.0-12.1 9.0.12 1.3-12 5.2.0 2.4.1
9.0-12.2 9.0.12 1.3-12 5.2.0 2.4.1
9.0-12.3 9.0.12 1.3-12 5.2.0 2.4.1
9.0-13 9.0.13 1.3-13 5.2.0 2.4.1
9.0-13.1 9.0.13 1.3-13 5.2.0 2.4.1
9.0-13.2 9.0.13 1.3-13 5.2.0 2.4.1
9.0-13.3 9.0.13 1.3-13 5.2.0 2.4.1
9.0-13.4 9.0.13 1.3-13 5.2.0 2.4.1
9.0-13.5 9.0.13 1.3-13 5.2.0 2.4.1
9.0-13.6 9.0.13 1.3-13 5.2.0 2.4.1
10.0-1 10.0.1 1.4-1 4.2.0 2.2.0
10.0-2 10.0.2 1.4-2 5.0.0 2.3.0
10.0-2.1 10.0.2 1.4-2 5.0.0 2.3.0
10.0-3 10.0.3 1.4-3 5.0.1 2.3.2
10.0-4 10.0.4 1.4-4 5.2.0 2.4.1
10.0-4.1 10.0.4 1.4-4 5.2.0 2.4.1
10.0-4.2 10.0.4.2 1.4-4 5.2.0 2.4.1
10.0-4.3 10.0.4.2 1.4-4 5.2.0 2.4.1
10.0-4.4 10.0.4.2 1.4-4 5.2.0 2.4.1
10.0-5 10.0.5 1.4-5 5.2.0 2.4.1
10.0-5.1 10.0.5 1.4-5 5.2.0 2.4.1
10.0-5.2 10.0.5.2 1.4-5 5.2.0 2.4.1
10.0-5.3 10.0.5 1.4-5 5.2.0 2.4.1
10.0-6 10.0.6 1.4-6 5.3.2 2.5.0
10.0-6.1 10.0.6.1 1.4-6 5.3.2 2.5.0
10.0-6.2 10.0.6.1 1.4-6 5.3.2 2.5.0
10.0-6.3 10.0.6.1 1.4-6 5.3.2 2.5.0
10.0-6.4 10.0.6.1 1.4-6 5.3.2 2.5.0
10.0-7 10.0.7 1.4-7 5.3.2 2.5.0
10.0-7.1 10.0.7 1.4-7 5.3.2 2.5.0
10.0-7.2 10.0.7 1.4-7 5.3.2 2.5.0
10.0-7.3 10.0.7 1.4-7 5.3.2 2.5.0
10.0-8 10.0.8 1.4-8 5.3.2 2.5.0
10.0-8.1 10.0.8 1.4-8 5.3.2 2.5.0

Questions about versions not listed? Contact us.

This website uses cookies.

By continuing to use this website you are giving consent to cookies being used in accordance with the MarkLogic Privacy Statement.